Compile Bitcoin Core from Source on Ubuntu 16.04

Why Compile? The main reason to compile Bitcoin Core yourself is that it ensures you’ll always have access to the latest release. For example, the binary Bitcoin Core package for Ubuntu 14.04 32-bit currently fails to install, giving the error message “E: Unable to locate package bitcoin-qt” (the 64-bit version installs without a problem). Compiling and…

How to upgrade your Bitcore full node for Segwit

Why nodes need to upgrade for Segwit Once the new Segwit consensus rules are activated, bitcoin transactions will now contain additional transaction information, and some definitions for important transaction rules will be changing. Nodes which fail to upgrade to support Segwit will face major security risks, including the risk of double-spend transaction fraud. Learn more about the…